import Foundation
let pattern = #"\$([^$]*)\$([^$]*)\$([^$]*)\$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"$ goes $, and $ goes $."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"John${1}left${2}Bill${3}right"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)