re = /\$([^$]*)\$([^$]*)\$([^$]*)\$/m
str = '$ goes $, and $ goes $.'
subst = 'John${1}left${2}Bill${3}right'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result