package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\$([^$]*)\$([^$]*)\$([^$]*)\$`)
var str = `$ goes $, and $ goes $.`
var substitution = "John${1}left${2}Bill${3}right"
fmt.Println(re.ReplaceAllString(str, substitution))
}