using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\$\{\s*(?<path>[a-zA-Z_$]\w*(?:\.[a-zA-Z_$]\w*)*)\s*\}";
string input = @"Hello, ${ name } Hello, ${ 0name } Hello, { name }
Hello, ${ _name_01 } Hello, ${ name$ } Hello, ${ _name_01 }
Hello, ${ $_name_2 }
Hello, ${ user.name.first } ${ user.name.last }!
Hello, ${ type.user.name.first.f1 } { type.user.name.last }!
Hello, ${ type.0user.name.first.f1 } ${ type.$user.name.last }!
Hello, ${ type.$user0._name_.first.f1 } ${ type.user$.name.last }!
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}