import Foundation
let pattern = #"\$\{\s*(?<path>[a-zA-Z_$]\w*(?:\.[a-zA-Z_$]\w*)*)\s*\}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Hello, ${ name } Hello, ${ 0name } Hello, { name }
Hello, ${ _name_01 } Hello, ${ name$ } Hello, ${ _name_01 }
Hello, ${ $_name_2 }
Hello, ${ user.name.first } ${ user.name.last }!
Hello, ${ type.user.name.first.f1 } { type.user.name.last }!
Hello, ${ type.0user.name.first.f1 } ${ type.$user.name.last }!
Hello, ${ type.$user0._name_.first.f1 } ${ type.user$.name.last }!
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)