// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\$\{\s*(?<path>[a-zA-Z_$]\w*(?:\.[a-zA-Z_$]\w*)*)\s*\}").unwrap();
let string = "Hello, ${ name } Hello, ${ 0name } Hello, { name }
Hello, ${ _name_01 } Hello, ${ name$ } Hello, ${ _name_01 }
Hello, ${ $_name_2 }
Hello, ${ user.name.first } ${ user.name.last }!
Hello, ${ type.user.name.first.f1 } { type.user.name.last }!
Hello, ${ type.0user.name.first.f1 } ${ type.$user.name.last }!
Hello, ${ type.$user0._name_.first.f1 } ${ type.user$.name.last }!
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}