re = /\$\{\s*(?<path>[a-zA-Z_$]\w*(?:\.[a-zA-Z_$]\w*)*)\s*\}/
str = 'Hello, ${ name } Hello, ${ 0name } Hello, { name }
Hello, ${ _name_01 } Hello, ${ name$ } Hello, ${ _name_01 }
Hello, ${ $_name_2 }
Hello, ${ user.name.first } ${ user.name.last }!
Hello, ${ type.user.name.first.f1 } { type.user.name.last }!
Hello, ${ type.0user.name.first.f1 } ${ type.$user.name.last }!
Hello, ${ type.$user0._name_.first.f1 } ${ type.user$.name.last }!
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end