import re
regex = re.compile(r"\$\{\s*(?<path>[a-zA-Z_$]\w*(?:\.[a-zA-Z_$]\w*)*)\s*\}")
test_str = ("Hello, ${ name } Hello, ${ 0name } Hello, { name }\n"
"Hello, ${ _name_01 } Hello, ${ name$ } Hello, ${ _name_01 }\n"
"Hello, ${ $_name_2 }\n"
"Hello, ${ user.name.first } ${ user.name.last }!\n"
"Hello, ${ type.user.name.first.f1 } { type.user.name.last }!\n"
"Hello, ${ type.0user.name.first.f1 } ${ type.$user.name.last }!\n"
"Hello, ${ type.$user0._name_.first.f1 } ${ type.user$.name.last }!\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")