# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\/[0-9]{4}-[0-9]{1,2}-[0-9]{1,2}$/\//gm;t' <<< "my-file-path/wefw/wefw/2022-03-20
my-file-path/wefw/2022-01-02
my-file-path/wef/wfe/wefw/wef/2021-02-03
my-file-path/wef/wfe/wef/"