import re
regex = re.compile(r"/[0-9]{4}-[0-9]{1,2}-[0-9]{1,2}$", flags=re.MULTILINE)
test_str = ("my-file-path/wefw/wefw/2022-03-20\n"
"my-file-path/wefw/2022-01-02\n"
"my-file-path/wef/wfe/wefw/wef/2021-02-03\n"
"my-file-path/wef/wfe/wef/")
subst = "/"
result = regex.sub(subst, test_str)
if result:
print(result)