#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)/[0-9]{4}-[0-9]{1,2}-[0-9]{1,2}$"
Local $sString = "my-file-path/wefw/wefw/2022-03-20" & @CRLF & _
"my-file-path/wefw/2022-01-02" & @CRLF & _
"my-file-path/wef/wfe/wefw/wef/2021-02-03" & @CRLF & _
"my-file-path/wef/wfe/wef/"
Local $sSubst = "/"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)