// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)/[0-9]{4}-[0-9]{1,2}-[0-9]{1,2}$").unwrap();
let string = "my-file-path/wefw/wefw/2022-03-20
my-file-path/wefw/2022-01-02
my-file-path/wef/wfe/wefw/wef/2021-02-03
my-file-path/wef/wfe/wef/";
let substitution = "/";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}