import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "/[0-9]{4}-[0-9]{1,2}-[0-9]{1,2}$";
final String string = "my-file-path/wefw/wefw/2022-03-20\n"
+ "my-file-path/wefw/2022-01-02\n"
+ "my-file-path/wef/wfe/wefw/wef/2021-02-03\n"
+ "my-file-path/wef/wfe/wef/";
final String subst = "/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}