use strict;
my $str = 'my-file-path/wefw/wefw/2022-03-20
my-file-path/wefw/2022-01-02
my-file-path/wef/wfe/wefw/wef/2021-02-03
my-file-path/wef/wfe/wef/';
my $regex = qr`/[0-9]{4}-[0-9]{1,2}-[0-9]{1,2}$`mp;
my $subst = '/';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";