re = /\/[0-9]{4}-[0-9]{1,2}-[0-9]{1,2}$/m
str = 'my-file-path/wefw/wefw/2022-03-20
my-file-path/wefw/2022-01-02
my-file-path/wef/wfe/wefw/wef/2021-02-03
my-file-path/wef/wfe/wef/'
subst = '/'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result