# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^|\W)(#.*?(?= #|$))/$1<span>$2<\/span>/gm;t' <<< "text text text text #tag1 #tag2 tag2secondWord #tag3 / withSlash #tag4 #tag5"