#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(^|\W)(#.*?(?= #|$))"
Local $sString = "text text text text #tag1 #tag2 tag2secondWord #tag3 / withSlash #tag4 #tag5"
Local $sSubst = "$1<span>$2</span>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)