import Foundation
let pattern = ##"(^|\W)(#.*?(?= #|$))"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"text text text text #tag1 #tag2 tag2secondWord #tag3 / withSlash #tag4 #tag5"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1<span>$2</span>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)