use strict;
my $str = 'text text text text #tag1 #tag2 tag2secondWord #tag3 / withSlash #tag4 #tag5';
my $regex = qr/(^|\W)(#.*?(?= #|$))/mp;
my $subst = '$1<span>$2</span>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";