const regex = /(^|\W)(#.*?(?= #|$))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|\\W)(#.*?(?= #|$))', 'gm')
const str = `text text text text #tag1 #tag2 tag2secondWord #tag3 / withSlash #tag4 #tag5`;
const subst = `$1<span>$2</span>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);