import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^|\\W)(#.*?(?= #|$))";
final String string = "text text text text #tag1 #tag2 tag2secondWord #tag3 / withSlash #tag4 #tag5";
final String subst = "$1<span>$2</span>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}