# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^|\W)(#.*?(?= #|$))"
test_str = "text text text text #tag1 #tag2 tag2secondWord #tag3 / withSlash #tag4 #tag5"
subst = "$1<span>$2</span>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.