$re = '/(^|\W)(#.*?(?= #|$))/m';
$str = 'text text text text #tag1 #tag2 tag2secondWord #tag3 / withSlash #tag4 #tag5';
$subst = "$1<span>$2</span>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;