#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\w+-\d+-\d+-\d+-\d+\.[^\.]+\.(?:[\w-]+[-.])?amazonaws\.com|.*temp\.domains|\w+-\w+\.[^\.]+\.azurewebsites\.net|[\w-]+\.[\w-]+\.elb\.amazonaws\.com)$"
Local $sString = "ec2-52-2-400-146.compute-1.amazonaws.com" & @CRLF & _
"kubernetes-52-2-400-146.container-1.amazonaws.com" & @CRLF & _
"ec2-52-2-400-146.eu-central-1.compute-amazonaws.com" & @CRLF & _
"ec2-52-2-400-146.eu-central-1.kub-container-amazonaws.com" & @CRLF & _
"ec2-52-2-400-146.eu-central-1.compute.amazonaws.com" & @CRLF & _
"" & @CRLF & _
"# Bluehost" & @CRLF & _
"box200000.temp.domains" & @CRLF & _
"" & @CRLF & _
"# Azure Websites" & @CRLF & _
"testest-dvd2e7fed7da2wh9.eastus2-01.azurewebsites.net" & @CRLF & _
"" & @CRLF & _
"# AWS Elastic Beanstalk" & @CRLF & _
"si-web-111111.eu-central-1.elb.amazonaws.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")