package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\w+-\d+-\d+-\d+-\d+\.[^\.]+\.(?:[\w-]+[-.])?amazonaws\.com|.*temp\.domains|\w+-\w+\.[^\.]+\.azurewebsites\.net|[\w-]+\.[\w-]+\.elb\.amazonaws\.com)$`)
var str = `ec2-52-2-400-146.compute-1.amazonaws.com
kubernetes-52-2-400-146.container-1.amazonaws.com
ec2-52-2-400-146.eu-central-1.compute-amazonaws.com
ec2-52-2-400-146.eu-central-1.kub-container-amazonaws.com
ec2-52-2-400-146.eu-central-1.compute.amazonaws.com
# Bluehost
box200000.temp.domains
# Azure Websites
testest-dvd2e7fed7da2wh9.eastus2-01.azurewebsites.net
# AWS Elastic Beanstalk
si-web-111111.eu-central-1.elb.amazonaws.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}