// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:\w+-\d+-\d+-\d+-\d+\.[^\.]+\.(?:[\w-]+[-.])?amazonaws\.com|.*temp\.domains|\w+-\w+\.[^\.]+\.azurewebsites\.net|[\w-]+\.[\w-]+\.elb\.amazonaws\.com)$").unwrap();
let string = "ec2-52-2-400-146.compute-1.amazonaws.com
kubernetes-52-2-400-146.container-1.amazonaws.com
ec2-52-2-400-146.eu-central-1.compute-amazonaws.com
ec2-52-2-400-146.eu-central-1.kub-container-amazonaws.com
ec2-52-2-400-146.eu-central-1.compute.amazonaws.com
# Bluehost
box200000.temp.domains
# Azure Websites
testest-dvd2e7fed7da2wh9.eastus2-01.azurewebsites.net
# AWS Elastic Beanstalk
si-web-111111.eu-central-1.elb.amazonaws.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}