$re = '/^(?:\w+-\d+-\d+-\d+-\d+\.[^\.]+\.(?:[\w-]+[-.])?amazonaws\.com|.*temp\.domains|\w+-\w+\.[^\.]+\.azurewebsites\.net|[\w-]+\.[\w-]+\.elb\.amazonaws\.com)$/m';
$str = 'ec2-52-2-400-146.compute-1.amazonaws.com
kubernetes-52-2-400-146.container-1.amazonaws.com
ec2-52-2-400-146.eu-central-1.compute-amazonaws.com
ec2-52-2-400-146.eu-central-1.kub-container-amazonaws.com
ec2-52-2-400-146.eu-central-1.compute.amazonaws.com
# Bluehost
box200000.temp.domains
# Azure Websites
testest-dvd2e7fed7da2wh9.eastus2-01.azurewebsites.net
# AWS Elastic Beanstalk
si-web-111111.eu-central-1.elb.amazonaws.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);