const regex = /^(?:\w+-\d+-\d+-\d+-\d+\.[^\.]+\.(?:[\w-]+[-.])?amazonaws\.com|.*temp\.domains|\w+-\w+\.[^\.]+\.azurewebsites\.net|[\w-]+\.[\w-]+\.elb\.amazonaws\.com)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\w+-\\d+-\\d+-\\d+-\\d+\\.[^\\.]+\\.(?:[\\w-]+[-.])?amazonaws\\.com|.*temp\\.domains|\\w+-\\w+\\.[^\\.]+\\.azurewebsites\\.net|[\\w-]+\\.[\\w-]+\\.elb\\.amazonaws\\.com)$', 'gm')
const str = `ec2-52-2-400-146.compute-1.amazonaws.com
kubernetes-52-2-400-146.container-1.amazonaws.com
ec2-52-2-400-146.eu-central-1.compute-amazonaws.com
ec2-52-2-400-146.eu-central-1.kub-container-amazonaws.com
ec2-52-2-400-146.eu-central-1.compute.amazonaws.com
# Bluehost
box200000.temp.domains
# Azure Websites
testest-dvd2e7fed7da2wh9.eastus2-01.azurewebsites.net
# AWS Elastic Beanstalk
si-web-111111.eu-central-1.elb.amazonaws.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}