import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\w+-\\d+-\\d+-\\d+-\\d+\\.[^\\.]+\\.(?:[\\w-]+[-.])?amazonaws\\.com|.*temp\\.domains|\\w+-\\w+\\.[^\\.]+\\.azurewebsites\\.net|[\\w-]+\\.[\\w-]+\\.elb\\.amazonaws\\.com)$";
final String string = "ec2-52-2-400-146.compute-1.amazonaws.com\n"
+ "kubernetes-52-2-400-146.container-1.amazonaws.com\n"
+ "ec2-52-2-400-146.eu-central-1.compute-amazonaws.com\n"
+ "ec2-52-2-400-146.eu-central-1.kub-container-amazonaws.com\n"
+ "ec2-52-2-400-146.eu-central-1.compute.amazonaws.com\n\n"
+ "# Bluehost\n"
+ "box200000.temp.domains\n\n"
+ "# Azure Websites\n"
+ "testest-dvd2e7fed7da2wh9.eastus2-01.azurewebsites.net\n\n"
+ "# AWS Elastic Beanstalk\n"
+ "si-web-111111.eu-central-1.elb.amazonaws.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}