# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:\w+-\d+-\d+-\d+-\d+\.[^\.]+\.(?:[\w-]+[-.])?amazonaws\.com|.*temp\.domains|\w+-\w+\.[^\.]+\.azurewebsites\.net|[\w-]+\.[\w-]+\.elb\.amazonaws\.com)$"
test_str = ("ec2-52-2-400-146.compute-1.amazonaws.com\n"
"kubernetes-52-2-400-146.container-1.amazonaws.com\n"
"ec2-52-2-400-146.eu-central-1.compute-amazonaws.com\n"
"ec2-52-2-400-146.eu-central-1.kub-container-amazonaws.com\n"
"ec2-52-2-400-146.eu-central-1.compute.amazonaws.com\n\n"
"# Bluehost\n"
"box200000.temp.domains\n\n"
"# Azure Websites\n"
"testest-dvd2e7fed7da2wh9.eastus2-01.azurewebsites.net\n\n"
"# AWS Elastic Beanstalk\n"
"si-web-111111.eu-central-1.elb.amazonaws.com")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.