using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\w+-\d+-\d+-\d+-\d+\.[^\.]+\.(?:[\w-]+[-.])?amazonaws\.com|.*temp\.domains|\w+-\w+\.[^\.]+\.azurewebsites\.net|[\w-]+\.[\w-]+\.elb\.amazonaws\.com)$";
string input = @"ec2-52-2-400-146.compute-1.amazonaws.com
kubernetes-52-2-400-146.container-1.amazonaws.com
ec2-52-2-400-146.eu-central-1.compute-amazonaws.com
ec2-52-2-400-146.eu-central-1.kub-container-amazonaws.com
ec2-52-2-400-146.eu-central-1.compute.amazonaws.com
# Bluehost
box200000.temp.domains
# Azure Websites
testest-dvd2e7fed7da2wh9.eastus2-01.azurewebsites.net
# AWS Elastic Beanstalk
si-web-111111.eu-central-1.elb.amazonaws.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}