# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d),(\d)/$1|$2/gm;t' <<< "Dow,John
12345,09876
13568,08642,1,2,3,4,5"