import re
regex = re.compile(r"(\d),(\d)", flags=re.MULTILINE)
test_str = ("Dow,John\n"
"12345,09876\n"
"13568,08642,1,2,3,4,5")
subst = "$1|$2"
result = regex.sub(subst, test_str)
if result:
print(result)