// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d),(\d)").unwrap();
let string = "Dow,John
12345,09876
13568,08642,1,2,3,4,5";
let substitution = "$1|$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}