re = /(\d),(\d)/m
str = 'Dow,John
12345,09876
13568,08642,1,2,3,4,5'
subst = '$1|$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result