const regex = /(\d),(\d)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d),(\\d)', 'gm')
const str = `Dow,John
12345,09876
13568,08642,1,2,3,4,5`;
const subst = `$1|$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);