use strict;
my $str = 'Dow,John
12345,09876
13568,08642,1,2,3,4,5';
my $regex = qr/(\d),(\d)/mp;
my $subst = '$1|$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";