#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)I love (cat|dog[s])"
Local $sString = "# or(|)(或): / cat|dog /" & @CRLF & _
"" & @CRLF & _
"#下方為測試文字區塊" & @CRLF & _
"I love cat." & @CRLF & _
"I love cats." & @CRLF & _
"I love dog." & @CRLF & _
"I love dogs." & @CRLF & _
"" & @CRLF & _
"#解釋:藍色部分就是透過規則/I love (cat|dog[s])/所配對成功的文字。" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")