// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)I love (cat|dog[s])").unwrap();
let string = "# or(|)(或): / cat|dog /
#下方為測試文字區塊
I love cat.
I love cats.
I love dog.
I love dogs.
#解釋:藍色部分就是透過規則/I love (cat|dog[s])/所配對成功的文字。
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}