import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "I love (cat|dog[s])";
final String string = "# or(|)(或): / cat|dog /\n\n"
+ "#下方為測試文字區塊\n"
+ "I love cat.\n"
+ "I love cats.\n"
+ "I love dog.\n"
+ "I love dogs.\n\n"
+ "#解釋:藍色部分就是透過規則/I love (cat|dog[s])/所配對成功的文字。\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}