package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)I love (cat|dog[s])`)
var str = `# or(|)(或): / cat|dog /
#下方為測試文字區塊
I love cat.
I love cats.
I love dog.
I love dogs.
#解釋:藍色部分就是透過規則/I love (cat|dog[s])/所配對成功的文字。
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}