using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"I love (cat|dog[s])";
string input = @"# or(|)(或): / cat|dog /
#下方為測試文字區塊
I love cat.
I love cats.
I love dog.
I love dogs.
#解釋:藍色部分就是透過規則/I love (cat|dog[s])/所配對成功的文字。
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}