$re = '/I love (cat|dog[s])/m';
$str = '# or(|)(或): / cat|dog /
#下方為測試文字區塊
I love cat.
I love cats.
I love dog.
I love dogs.
#解釋:藍色部分就是透過規則/I love (cat|dog[s])/所配對成功的文字。
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);