import re
regex = re.compile(r"I love (cat|dog[s])", flags=re.MULTILINE)
test_str = ("# or(|)(或): / cat|dog /\n\n"
"#下方為測試文字區塊\n"
"I love cat.\n"
"I love cats.\n"
"I love dog.\n"
"I love dogs.\n\n"
"#解釋:藍色部分就是透過規則/I love (cat|dog[s])/所配對成功的文字。\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")