#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(Mazurka)(.+), (Op.+)"
Local $sString = "Mazurka in A minor, Op. 7, No. 2"
Local $sSubst = "$1 $3$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)