using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(Mazurka)(.+), (Op.+)";
string substitution = @"$1 $3$2";
string input = @"Mazurka in A minor, Op. 7, No. 2";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}