package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(Mazurka)(.+), (Op.+)`)
var str = `Mazurka in A minor, Op. 7, No. 2`
var substitution = "$1 $3$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}