$re = '/(Mazurka)(.+), (Op.+)/m';
$str = 'Mazurka in A minor, Op. 7, No. 2';
$subst = "$1 $3$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;