const regex = /(Mazurka)(.+), (Op.+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(Mazurka)(.+), (Op.+)', 'gm')
const str = `Mazurka in A minor, Op. 7, No. 2`;
const subst = `$1 $3$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);