re = /(Mazurka)(.+), (Op.+)/m
str = 'Mazurka in A minor, Op. 7, No. 2'
subst = '$1 $3$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result